Техническая поддержка :

Современные решения

для защиты Windows программ

и восстановления исходного кода

Руководство по Visual Basic


Глобальные клавиши быстрого вызова

Следующие сочетания клавиш используются во всех окнах Visual Basic:

Сочетание клавиш

Действие

 

F5

Запуск подпрограммы/формы или макроса.

F8

Шаг с заходом в процедуру.

SHIFT+F8

Выполнение одной строки инструкций, без входа в процедуры.

CTRL+BREAK

Прерывание выполнения программы Visual Basic.

CTRL+G

Отображение она проверки

ALT+F5

Запуск программы обработки ошибки или возврат ошибки в вызвавшую процедуру. Не влияет на установки по отслеживанию ошибок, сделанные на вкладке Общие окна диалога Параметры.

ALT+F8

Вход в процедуру обработки ошибки или возврат ошибки в вызвавшую процедуру. Не влияет на установки по отслеживанию ошибок, сделанные на вкладке Общие окна диалога Параметры.

CTRL+TAB

Переключение между окнами.

Клавиши быстрого вызова в окне UserForm

В окне UserForm используются следующие сочетания клавиш:

Сочетание клавиш

Действие

 

SHIFT+CTRL+БУКВА

Выбор свойства из списка свойств в окне свойств.

БУКВА

Ввод значения выбранного свойства в окне свойств.

F7

Открытие для выделенного объекта окна модуля.

DEL или DELETE

Удаление выделенных элементов удаления без помещения в буфер обмена.

CTRL+Z

Отмена удаления элементов управления.

TAB

Циклическое перемещение вперед от одного элемента управления к другому в последовательности перехода.

SHIFT+TAB

Циклическое перемещение назад от одного элемента управления к другому в последовательности перехода.

CTRL+НАЖАТИЕ КНОПКИ МЫШИ

Добавление или исключение элемента управления из выделенной группы.

НАЖАТИЕ КНОПКИ МЫШИ+ПЕРЕМЕЩЕНИЕ МЫШИ

Выбор нескольких элементов управления.

SHIFT+ НАЖАТИЕ КНОПКИ МЫШИ

Выбор нескольких элементов управления.

CTRL+ НАЖАТИЕ КНОПКИ МЫШИ +ПЕРЕМЕЩЕНИЕ МЫШИ

Добавление или исключение элементов управления из выделенной группы.

F4

Отображение окна свойств (только во время разработки).

SHIFT+F10

Вызов контекстного меню.

CTRL+J

Помещение элементов управления на передний план (влияет на перекрывающиеся элементы управления только во время разработки).

CTRL+K

Помещение элементов управления на задний план (влияет на перекрывающиеся элементы управления только во время разработки).

Чтобы снять выделение со всех элементов управления следует выбрать мышью форму. Чтобы выбрать отдельные элементы из выделенной группы, следует снять выделение с группы, а затем с помощью нажатия и удержания клавиши CTRL, кнопки мыши и перемещения мыши выделить нужные элементы.

Команда "Параметры" (меню "Сервис")

Команда выводит окно диалога "Параметры", где возможен выбор вкладки для установки параметров среды программирования Visual Basic.

Вкладки

Редактор

Формат

Общие

Закрепление

Команда Удалить <Элемент>... (меню Файл)

Удаляет активную форму или модуль из проекта. Команда недоступна, если в окне проекта не выделен ни один элемент.

При удалении из проекта модуля необходимо убедиться, что в оставшейся программе нет ссылок на удаляемые элементы.

Перед удаление элемента выдается запрос, следует ли экспортировать этот элемент в файл. Если в окне сообщения нажать кнопку Да, появится окно диалога Экспорт файла. Если ответить Нет, элемент будет удален.

Важно. Эта команда не может быть отменена.

Команды Очистить и Удалить (меню Правка)

Очистить Удаляет текст, только когда активен модуль.

Удалить В других случаях название изменяется на Удалить. Команда удаляет выделенный элемент управления, текст, или контрольное выражение. Команда может быть отменена в окне модуля или в форме, если удален элемент управления.

Кнопка панели инструментов: . . Клавиша быстрого вызова: DEL.

Не доступна во время выполнения.

Команда Импорт файла и Экспорт файла (меню "Файл")

Добавляет в проект существующие модули и формы или сохраняет модули и формы проекта в виде отдельного файла.

Импорт файла Отображает окно диалога импорта файлов, в котором в проект добавляется существующие форма или модуль. В проект добавляется копия исходного файла, а сам файл остается нетронутым. При добавлении формы или модуля, имя которых совпадает с существующим в проекте, к имени файла добавляется число.

Импортированные компоненты отображаются в окне проекта.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+M.

Экспорт файла Отображает окно диалога экспорта файла для извлечения из проекта активных формы или модуля. Файл копируется во внешний.

Команда недоступна если в окне проекта не выбран файл.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+E.

Команда Сброс <проект> (меню Запуск)

Очищает стек вызова, а также переменные уровня модуля..

Кнопка панели инструментов: .

Команды Конструктор и Выход из конструктора (меню "Запуск")

Включает или выключает для проекта режим конструктора. Режим конструктора - период времени, в течении которого в проекте не выполняется ни одна программа. Выход из этого режима может быть осуществлен с помощью выполнения макроса или использования области проверки.

Конструктор Выполняет переход в режим конструктора и изменяется на Выход из конструктора.

Выход из конструктора Выполняет выход из режима конструктора и очищает все переменные уровня модуля в проекте.

Кнопка панели инструментов:

Команда UserForm (меню Вставка)

Создает новую форму и добавляет ее в проект.

Команды Запуск подпрограммы/формы, Продолжить и Запуск макроса (меню "Запуск")

Запуск подпрограммы/формы Если курсор находится в процедуре, запускает текущую процедуру. Если же активна форма, будет запущена она. В режиме прерывания команда изменяется на Продолжить.

Если ни окно модуля, ни UserForm не активны, название команды изменяется на Запуск макроса.

Продолжить Возобновляет выполнение текущей процедуры или формы.

Запуск макроса Запускает макрос.

Команда Закрыть и вернуться в <приложение> (меню "Файл")

Закрывает среду разработчика и возвращает пользователя в главное приложение. Visual Basic скрывается, но остается в памяти.

Команда Компилировать <проект> (меню Отладка)

Компилирует проект.

Кнопка панели инструментов: .

Команда Объект (меню "Вставка")

Вставляет в активную форму объект.

Недоступна, если нет открытых форм, а также в режиме прерывания.

Кнопка панели инструментов: .

Команда Сохранить <документ> (меню "Файл")

Сохраняет текущий проект, а также все его компоненты - формы и модули - в виде документа.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+5.

Команда Макрос (меню Сервис)

Отображает окно диалога Макрос для создания, изменения, удаления и запуска макросов.

Команда <приложение> (меню "Вид")

Помещает приложение на передний план редактора Visual Basic для удобного просмотра. Название команды изменяется на имя приложения.

Клавиша быстрого вызова: ALT+F11.

Команда Процедура (меню "Вставка")

Добавляет в активный модуль процедуру Sub, процедуру Function или процедуру Property.

Доступна только в окне модуля.

Кнопка панели инструментов: .

Команды Модуль и Модуль класса (меню "Вставка")

Модуль Создает новый стандартный модуль и добавляет его в активный проект.

Кнопка панели инструментов:

Модуль класса Создает новый модуль класса и добавляет его в активный проект.

Кнопка панели инструментов:

Команда Файл (меню "Вставка")

Отображает окно диалога Вставка файла для добавления текста существующего модуля в текущее положение курсора.

Доступна только в редакторе.

Команда Порядок перехода (меню "Вид")

Для активной формы отображает окно диалога Последовательность перехода.

Кнопка панели инструментов:

Команды Группировать и Разделить (меню "Формат")

Группирует или разгруппирует выделенные объекты.

Группировать Создает группу.

Примечание. Сохраняется возможность выбора одного элемента группы и изменение его свойств.

Примечание. Не допускается создание групп внутри группы (вложенная группировка).

Кнопка панели инструментов: .

Разделить Разгруппирует ранее сгруппированные объекты,.

Кнопка панели инструментов: .

Команды Упорядочить кнопки (меню "Формат")

Располагает выделенные кнопки вдоль горизонтального или вертикального края формы.

Упорядочить по нижнему краю Располагает кнопки вдоль нижней границы формы с равными промежутками.

Кнопка панели инструментов:

Упорядочить по правому краю Располагает кнопки вдоль правой границы формы с равными промежутками.

Кнопка панели инструментов:

Команда Подогнать размер (меню "Формат")

Изменяет высоту и ширину объекта так, чтобы в нем полностью помещалось содержимое.

Кнопка панели инструментов:

Команда Ссылки (меню "Сервис")

Отображает окно диалога Ссылки, где возможно добавление в проект ссылки на объектную библиотеку или библиотеку типов.. Это делает объекты других приложений доступными в программе. При установке ссылки соответствующие объекты появляются в окне просмотра объектов.

Допускается добавление ссылок на другие загруженные или сохраненные проекты. Если проект не был сохранен, он отображается в виде "НЕСОХРАНЕННЫЙ: <ИмяПроекта>" и установка ссылок на него невозможна.

Команда доступна только во время разработки.

Команда Дополнительные элементы... (меню "Сервис")

Отображает окно диалога Дополнительные элементы, используемое для добавления на панель элементов дополнительных элементов управления и вставляемых объектов (таких как документ Microsoft Word).

Команда Свойства <имя проекта>... (меню "Сервис")

Отображает окно диалога свойств проекта, используемое для установки защиты и необходимых параметров проекта.

Кнопка панели инструментов: .

Команда Удалить страницу (контекстное меню)

Удаляет выбранную страницу панели элементов.

Команды Импорт страницы и Экспорт страницы (контекстное меню)

Импортирует и экспортирует страницы.

Импорт страницы Отображает окно диалога Импорт страницы, где выполняется поиск и выбор станицы, добавляемой к панели элементов.

Окно диалога Импорт страницы является стандартным окном открытия файла в Windows.

Экспорт страницы Отображает окно диалога Экспорт страницы, где для экспортируемой из панели элементов страницы задается новое имя и местоположение.

Окно диалога Экспорт страницы является стандартным окном сохранения файла в Windows.

Команда Создать страницу (контекстное меню)

Добавляет новую страницу с именем Новая страница. Для изменения имени служит команда Переименовать контекстного меню.

Допускается наличие нескольких страниц с именем Новая страница.

При добавлении к панели элементов новой страницы, в нее автоматически включается инструмент Выбор объектов.

Команда Переименовать (контекстное меню)

Отображает окно диалога Переименовать, где возможно изменение имени выделенной страницы, создание для нее клавиши быстрого вызова или подсказки.

Параметры окна диалога

Подпись Позволяет задать новое имя страницы.

Текст подсказки Позволяет создать подсказку для страницы.

Команда Удалить <Элемент> (контекстное меню)

Удаляет выделенный элемент панели элементов. Для добавления элемента служит команда Дополнительные элементы... контекстного меню.

Команда Изменить <Элемент> (контекстное меню)

Отображает окно диалога изменения элемента управления, где для выделенного элемента возможно изменение текста подсказки или значка.

Команда Дополнительные элементы... (контекстное меню)

Отображает окно диалога изменения элемента управления для добавления элементов управления и вставляемых объектов.

Команда Вставить объект... (контекстное меню)

Отображает окно диалога вставики объекта.

Команды Копировать и Переместить (контекстное меню)

Позволяет использовать операции перемещения с помощью мыши над элементами управления в форме. С помощью правой кнопки мыши следует выбрать элемент управления и затем, не отпуская кнопки, переместить его в нужное положение. После отпускания кнопки появляется контекстное меню, содержащее команды.

Копировать Копирует выделенный элемент управления в новое место.

Переместить Перемещает выделенный элемент управления в новое место.

Отменить Отменяет операцию.

Справка по Microsoft Visual Basic

Если помощник по Office не виден, отображает его и окно подсказок. Если помощник виден, отображает окно подсказок.

Кнопка панели инструментов: . Клавиша быстрого вызова: F1.

Вызов справки

Отображает окно диалога справки по Visual Basic, в котором возможен поиск по алфавитному указателю или полный поиск текста.

Кнопка панели инструментов: .

Microsoft на Web

Выполняет соединение с Интернет для получения дополнительных сведений и поддержки.

Для использования этой команды необходимо иметь модем или быть подключенным к Интерент и средству просмотра Worldwide Web.

О программе

Отображает окно диалога, содержащее номер версии, сведения об авторстве и информацию о системе.

Стандартная панель инструментов

Содержит кнопки для быстрого вызова наиболее часто используемых команд меню.

Для выполнения действия, закрепленного за кнопкой, следует нажать ее. Для отображения краткой справки о кнопках панели инструментов достаточно установить флажок Всплывающие подсказки на вкладке Общие окна диалога Параметры.

Кнопки панели инструментов

Отобразить <приложение>

Выполняет переключение между приложением и активным документом Visual Basic.

Вставить

Отображает меню для выбора вставляемого в активный проект объекта. Значок на кнопке изменяется на изображение последнего вставленного объекта. По умолчанию это форма.

- UserForm

- Модуль

- Модуль класса

- Процедура

Сохранить <имя документа>

Сохраняет документ, включая проект и все его компоненты - формы и модули.

Вырезать

Удаляет выделенный элемент управления или текст в буфер обмена.

Копировать

Копирует выделенный элемент управления или текст в буфер обмена.

Вставить

Вставляет содержимое буфера обмена в текущую позицию.

Найти

Отображает окно диалога Поиск и выполняет поиск текста, заданного в поле Образец.

Отмена

Отменяет последнюю операцию редактирования.

Возврат

Отменяет последнюю команду Отмена, если после ее вызова не произошло никаких других событий.

Запуск подпрограммы/формы или Запуск макроса

Если курсор находится внутри процедуры - запускает процедуру, если активна UserForm - запускает UserForm, иначе запускает макрос.

Прервать

Останавливает выполнение программы и выполняет переход в режим прерывания.

Сброс <проекта>

Очищает стек выполнения, переменные уровня модуля и выполняет сброс проекта.

Режим конструктора

Включает и выключает режим конструктора.

Окно проекта

Отображает окно проекта, в котором выводится иерархический список открытых проектов и их содержимого.

Окно свойств

Отображает окно свойств, используемое для просмотра свойств выделенного элемента управления.

Просмотр объектов

Отображает окно просмотра объектов, в котором выводится список библиотек объектов, библиотек типов, классов, методов, свойств, событий и констант, доступных для использования в программе, а также описанные в проекте модули и процедуры.

Панель элементов

Отображает либо скрывает панель элементов, содержащую все доступные в приложении элементы управления и вставляемые объекты (такие как диаграмма Microsoft Excel). Доступна только когда активна UserForm.

Помощник по Office

Отображает помощника по Office, используемого для получения справки о команде, окне диалога или активном окне.

Панель инструментов UserForm

Содержит кнопки для быстрого вызова наиболее часто используемых при работе с формами команд меню.

Для выполнения действия, закрепленного за кнопкой, следует нажать ее. Для отображения краткой справки о кнопках панели инструментов достаточно установить флажок Всплывающие подсказки на вкладке Общие окна диалога Параметры.

Кнопки панели инструментов

На передний план

Помещает выделенные объекты в форме перед всеми остальными.

На задний план

Помещает выделенные объекты в форме позади всех остальных.

Сгруппировать

Создает из выделенных объектов группу.

Разгруппировать

Выровнять

По левому краю - выравнивает горизонтальное положение выбранных объектов, помещая их левые границы на одну линию.

По центру - выравнивает горизонтальное положение выбранных объектов, помещая их центры на одну линию.

По правому краю - выравнивает горизонтальное положение выбранных объектов, помещая их правые границы на одну линию.

По верхнему краю - выравнивает вертикальное положение выбранных объектов, помещая их верхние границы на одну линию.

По середине - выравнивает вертикальное положение выбранных объектов, помещая их середины на одну линию.

По нижнему краю - выравнивает вертикальное положение выбранных объектов, помещая их нижние границы на одну линию.

По узлам сетки - помещает верхний левый угол выделенных объектов в ближайший узел сетки. Размер объектов не изменяется.

Центрировать

По горизонтали - центрирует выделенные объекты по горизонтали.

По вертикали - центрирует выделенные объекты по вертикали.

Выровнять размер

по ширине - Корректирует ширину.

по высоте - Корректирует высоту.

по ширине и высоте - Корректирует как ширину, так и высоту.

Масштаб

Уменьшает или увеличивает изображение всех элементов управления в UserForm. Допускается выбор коэффициента масштабирования в диапазоне от 10 до 400 процентов.

Панель инструментов Отладка

Содержит кнопки для быстрого вызова наиболее часто используемых при отладке команд меню.

Для выполнения действия, закрепленного за кнопкой, следует нажать ее. Для отображения краткой справки о кнопках панели инструментов достаточно установить флажок Всплывающие подсказки на вкладке Общие окна диалога Параметры.

Кнопки панели инструментов

Режим конструктора

Включает и выключает режим конструктора.

Запуск подпрограммы/формы или Запуск макроса

Если курсор находится внутри процедуры - запускает процедуру, если активна UserForm - запускает UserForm, иначе запускает макрос.

Прервать

Останавливает выполнение программы и выполняет переход в режим прерывания.

Сброс <проекта>

Очищает стек выполнения, переменные уровня модуля и выполняет сброс проекта.

Точка останова

Устанавливает или удаляет в текущей строке точку останова.

Шаг с заходом

Шаг с заходом в процедуру.

Шаг с обходом

Шаг с выполнением процедуры (перешагивание через процедуру).

Шаг с выходом

Выполняет оставшиеся инструкции процедуры, в которой находится текущая точка выполнения.

Область Локальные

Отображает область Локальные окна отладки.

Область проверки

Отображает область проверки окна отладки.

Область Контрольные

Отображает область Контрольные окна отладки.

Контрольное значение

Отображает окно диалога Контрольное значение, в котором выводится текущее значение выделенного выражения.

Стек вызова

Отображает окно диалога Стек вызова, в котором выводится список активных вызовов процедур (запущенных, но еще не завершившихся).

Панель инструментов Правка

Содержит кнопки для быстрого вызова наиболее часто используемых при редактировании текста программы команд меню.

Для выполнения действия, закрепленного за кнопкой, следует нажать ее. Для отображения краткой справки о кнопках панели инструментов достаточно установить флажок Всплывающие подсказки на вкладке Общие окна диалога Параметры.

Кнопки панели инструментов

Список свойств/методов

В окне модуля выводит раскрывающийся список, содержащий доступные для объекта свойства и методы.

Список констант

В окне модуля выводит раскрывающийся список, содержащий допустимые константы для введенного свойства, за которым следует знак равенства (=).

Краткие сведения

Выводит синтаксис использования выбранной в окне модуля переменной, функции, инструкции, метода или процедуры.

Сведения о параметре

В окне модуля выводит сведения о параметрах функции или инструкции, на которых установлен курсор.

Завершить слово

Завершает ввод набираемого слова, если только введено достаточно символов для распознавания слова Visual Basic.

Увеличить отступ

Смещает все выделенные строки в следующую позицию табуляции.

Уменьшить отступ

Смещает все выделенные строки в предыдущую позицию табуляции.

Точка останова

Устанавливает или удаляет в текущей строке точку останова.

Закомментировать блок

Добавляет в начало каждой строки выделенного блока текста символ комментария.

Раскомментировать блок

Добавляет из начала каждой строки выделенного блока текста символ комментария.

Закладка

Снимает или устанавливает закладку в текущей строке окна модуля.

Следующая закладка

Перемещает фокус к следующей закладке в стеке закладок.

Предыдущая закладка

Перемещает фокус к предыдущей закладке в стеке закладок.

Снять все закладки

Удаляет все закладки.

Окно диалога Параметры

Служит для изменения заданных по умолчанию настроек среды разработчика Visual Basic.

Окно диалога Параметры содержит следующие вкладки:

Редактор

Формат

Общие

Закрепление

Окно диалога Экспорт файла

Служит для задания имени и местоположения экспортируемого файла.

Параметры окна диалога

Папка

Служит для выбора папки, в которой будет сохранен файл.

Переход на один уровень вверх

Отображает список папок или дисков, находящихся на один уровень выше текущей папки.

Создать новую папку

Создает новую папку.

Сведения

Отображает папки и файлы в виде списка, включающего значок, имя, размер (только для документов), тип, дату и время последнего изменения.

Мелкие значки

Отображает папки и файлы в виде списка маленьких значков и имен.

Имя файла

Если не указано расширение имени файла, Visual Basic автоматически добавляет расширение по умолчанию: .frm для форм, .bas для модулей, .cls для модулей класса.

Тип файлов

Служит для выбора типа файла:

Файлы форм (*.frm) - отображает все формы.

Файлы программ на Basic (*.bas) - отображает все стандартные модули.

Файлы классов (*.cis) - отображает все модули класса.

Окно диалога Импорт файла

Позволяет выбрать импортируемый файл.

Параметры окна диалога

Папка

Служит для выбора папки, в которой находится открываемый проект.

Переход на один уровень вверх

Отображает список папок или дисков, находящихся на один уровень выше текущей папки.

Создать новую папку

Создает новую папку.

Мелкие значки

Отображает папки и проекты в виде списка маленьких значков и имен.

Сведения

Отображает папки и проекты в виде списка, включающего значок, имя, размер, тип, дату и время последнего изменения.

Имя файла

Служит для ввода или выбора имени импортируемого файла.

Тип файлов

Служит для выбора типа файла; по умолчанию задается тип Проект Visual Basic (*.frm, *.bas, *.cls). Файлы выбранного типа появляются в списке имен файлов.

Открыть

Открытие выбранного файла.

Отмена

Закрытие окна диалога без открытия проекта.

Панель элементов

Отображает стандартные элементы управления Visual Basic, а также все добавленные в проект элементы управления ActiveX и вставляемые объекты.

Допускается настройка панели элементов путем добавления к ней страниц или элементов управления с помощью команды Дополнительные элементы... из меню Сервис.

При добавлении страницы в нее автоматически вставляется инструмент Выбор объектов.

Стандартные элементы управления панели элементов

Выбор объектов

Это единственный инструмент на панели элементов, не создающий никаких элементов управления. Он служит для изменения размеров и положения элементов формы.

Надпись

Позволяет отобразить в форме неизменяемый текст, например подпись к рисунку.

Поле

Содержит вводимый и изменяемый пользователем текст.

Поле со списком

Вставляет объект, являющийся сочетанием списка и поля. Пользователь может либо выбрать нужное значение из списка, либо ввести его в поле.

Список

Вставляет список выбираемых пользователем элементов. Допускается прокручивание списка, если не все его элементы видны одновременно.

Флажок

Создает ячейку, которая может быть помечена пользователем, как имеющая значение истина или ложь, а также использующуюся для предоставления выбора нескольких вариантов.

Переключатель

Используется для предоставления выбора одного варианта из многих.

Выключатель

Создает кнопку, имеющую два состояния: включено и выключено.

Группа

Позволяет установить графическую или функциональную группировку элементов управления. Для создания группы следует сначала создать ее рамку, а затем внутри нее создать необходимые элементы.

Кнопка

Создает кнопку, при нажатии которой выполняется команда.

Набор вкладок

Позволяет создать несколько станиц в одной и той же области окна или окна диалога.

MultiPage

Служит для представления нескольких экранов информации в виде единого набора.

Полоса прокрутки

Создает графический инструмент для быстрого перемещения по длинным спискам элементов или по большим документам, отображающий текущее положение.

SpinButton

Прокручивающий элемент управления используется совместно с другими элементами для увеличения или уменьшения числовых значений. Допускается его использование для выбора объекта из диапазона значений или из списка элементов.

Рисунок

Отображает в форме точечный рисунок, значок или метафайл. Картинки в элементе управления рисунок являются декоративными и требуют меньше ресурсов, чем PictureBox.

Вкладка Общие (окно диалога "Параметры")

Задает параметры настройки, обработки ошибок и компиляции текущего проекта Visual Basic.

Параметры вкладки

Параметры сетки в форме Определяет внешний вид формы во время ее редактирования.

Показать сетку - определяет, показывать ли сетку.

Размеры сетки - отображает используемые для формы единицы сетки.

по ширине: - задает ширину ячеек сетки в форме (от 2 до 60 точек).

по высоте: - задает высоту ячеек сетки в форме (от 2 до 60 точек).

Привязка элементов к сетке - автоматически располагает внешние границы элементов управления на линиях сетки.

Всплывающие подсказки Отображает подсказку по кнопкам панели инструментов.

Скрытие окон при сбое Определяет, должно ли быть автоматически закрыто окно проекта, UserForm, объекта или модуля, при сворачивании проекта в окне проекта.

Правка и продолжение

Уведомить о потере состояния - определяет, должно ли отображаться сообщение, уведомляющее о том, что запрошенная операция приведет к сбросу всех переменных уровня модуля в проекте.

Перехват ошибок. Останов: Определяет способ обработки ошибок в среде разработчика Visual Basic. Изменение этих параметров будет влиять на все запущенные позднее копии Visual Basic.

Останов при любой ошибке - любая ошибка переводит проект в режим прерывания, независимо от того, активен ли обработчик ошибок и находится ли программа в модуле класса.

Останов в модуле класса - любая необрабатываемая ошибка в модуле класса переводит проект в режим прерывания на строке модуля класса, вызвавшей ошибку.

Останов на необрабатываемых ошибках - если обработчик ошибок активен, переход в режим прерывания не выполняется. Если же нет активного обработчика ошибок проект переводится в режим прерывания. Однако необрабатываемая ошибка в модуле класса переводит проект в режим прерывания на строке программы, вызвавшей процедуру, в которой произошла ошибка.

Компиляция

Компиляция по запросу - определяет, должен ли проект перед запуском быть скомпилирован полностью, либо по мере необходимости, что позволяет быстрее запустить приложение.

В фоновом режиме - определяет следует ли использовать времена простоя при работе приложения для завершения компиляции проекта в фоновом режиме. Это позволяет увеличить скорость выполнения. Эта возможность недоступна, если выбран параметр Компиляция по запросу .

Вкладка Формат (окно диалога "Параметры")

Определяет внешний вид программы на Visual Basic.

Параметры вкладки

Использование цвета Задает цвета фона и текста для типа выбранного в списке текста.

Текстовая область - список элементов с настраиваемыми цветами.

Текст - задает цвет текста, выбранного в списке Текстовая область.

Фон - задает цвет фона для текста, выбранного в списке Текстовая область

Индикатор - задает цвет индикатора на полях.

Шрифт Задает используемый для всего текста программы шрифт.

Размер Задает используемый для всего текста программы размер шрифта.

Индикатор полей Отображает или скрывает сроку индикаторов на полях.

Образец Отображает пример текста, оформленного с помощью выбранных атрибутов.

Вкладка Редактор (окно диалога "Параметры")

Определяет параметры настройки окна модуля и окна проекта.

Параметры вкладки

Программирование

Проверка синтаксиса - определяет, должен ли Visual Basic автоматически проверять правильность синтаксиса после ввода строки программы.

Явное описание переменных - определяет необходимость явного описания переменных в модулях. Выбор этого параметра приведет к добавлению инструкции Option Explicit в раздел общих описаний всех создаваемых модулей.

Список компонентов - отображает список данных, логически завершающих инструкцию, расположенную в месте вставки.

Краткие сведения - отображает сведения о функции и ее параметрах по мере ввода ее имени.

Подсказка значений - отображает значение переменной, на которой установлен курсор. Эта возможность доступна только в режиме прерывания.

Автоотступ - позволяет задавать положение табуляции только для первой строки - следующие строки будут начинаться с того же положения.

Интервал табуляции - устанавливает интервал табуляции в пределах от 1 до 32 пробелов; по умолчанию используется значение 4.

Параметры окна

Перетаскивание текста - позволяет использовать мышь для перемещения элементов внутри текущего окна модуля, а также между окном модуля и областями проверки и Контрольные.

Полный модуль - для вновь открываемых модулей устанавливает возможность просмотра в окне модуля как списка всех процедур, так одной конкретной процедуры. Этот параметр не влияет на просмотр в открытых модулях.

Разделитель процедур - позволяет скрывать и отображать разделяющую полосу, появляющуюся в конце каждой процедуры в окне модуля.

Окно диалога Редактор кнопок

Инструмент для изменения значков панели элементов.

Параметры окна диалога

Рисунок Поточечно отображает значок.

Переместить Перемещает рисунок, делая возможным работу с любой ее частью.

- при каждом нажатии перемещает картинку на один ряд точек вверх, пока не достигнут самый верхний ряд.

- при каждом нажатии перемещает картинку на один ряд точек вниз, пока не достигнут самый нижний ряд.

- при каждом нажатии перемещает картинку на один столбец точек вправо, пока не достигнут самый правый столбец.

- при каждом нажатии перемещает картинку на один столбец точек влево, пока не достигнут самый левый столбец.

Цвета Изменяет цвет точек. Для рисования следует сначала выбрать нужный цвет, а затем отметить точку, которую необходимо окрасить в этот цвет.

Удалить - Удаляет цвет со всех точек, выбранных с помощью мыши, после пометки данной ячейки.

Просмотр Отображает внешний вид редактируемого значка.

Очистить Удаляет картинку из поля рисования.

OK Назначает измененную картинку элементу управления.

Окно диалога Макрос

Позволяет запускать, изменять и удалять выделенный макрос. Допускается также создание макроса.

Параметры окна диалога

Имя макроса Содержит имя выделенного макроса или пусто, если в поле Макросы нет макросов.

Макросы Отображает список всех макросов в проекте, выделенном в поле Макросы в.

Макросы в Отображает список доступных проектов.

Выполнить Запускает выделенный макрос.

Шаг Выделяет цветом первую строку макроса и помещает в ней маркер текущей выполняемой строки.

Изменить Открывает окно модуля с выделенным макросом, в котором возможно его изменение.

Создать В окне модуля открывает модуль для создания нового макроса.

Удалить Удаляет выделенный макрос из проекта.

Вкладка Защита (окно диалога Свойства проекта)

Устанавливает защиту проекта.

Параметры окна диалога

Блокировка проекта Позволяет заблокировать проект и предотвратить его изменение посторонними лицами.

Блокировать проект для просмотра - Запрещает просмотр и изменение проекта.

Пароль для просмотра свойств проекта Устанавливает пароль, позволяющий просматривать свойства проекта.

Пароль - Установка пароля для проекта. Если параметр Блокировать проект для просмотра не выбран, но установлен пароль, для отображения окна свойств при следующем открытии проекта потребуется ввести этот пароль.

Подтверждение - Служит для подтверждения пароля, введенного в поле Пароль. При нажатии кнопки OK содержимое этих полей должно совпадать, иначе будет выведено сообщение об ошибке.

Окно диалога порядка страниц

Служит для изменения порядка страниц в наборе вкладок.

Параметры окна диалога

Порядок страниц Отображает список страниц-вкладок в порядке слева направо.

Вверх При каждом нажатии перемещает выделенную страницу на одну позицию вверх.

Вниз При каждом нажатии перемещает выделенную страницу на одну позицию вниз.

Окно диалога настройки элемента управления

Позволяет задать текст подсказки и изменить значок элемента управления.

Параметры окна диалога

Текст всплывающей подсказки Содержит текст подсказки для данного элемента.

Просмотр Отображает выбранный для элемента управления значок.

Изменить рисунок Отображает окно диалога, в котором возможно изменение значка.

Загрузить рисунок Отображает окно диалога Выбор рисунка. Это окно является стандартным окном открытия файла.

Вкладка Закрепление (окно диалога "Параметры")

Позволяет задать закрепленные окна. Окно считается закрепленным, когда его положение на экране, в окне приложения или в другом закрепленном окне зафиксировано. При перемещении такого окна оно остается "привязанным" к своему положению. Если окно может быть перемещено и оставлено в новом месте - оно не закреплено.

На этой вкладке следует пометить окна, которые необходимо закрепить, и снять пометку с остальных. Допускается закрепление любого числа окон.

Окно диалога Вставка объекта

Позволяет вставить в форму новый объект путем его создания или выбора из файла.

Параметры окна диалога

Создать новый Отображает список Тип объекта, в котором следует выбрать тип создаваемого объекта.

Тип объекта - список доступных объектов.

Создать из файла Отображает поле Файл и кнопку Обзор для выбора файла, вставляемого в форму в виде объекта.

Файл - Отображает имя и путь вставляемого файла.

Обзор - Открывает стандартное окно просмотра для поиска вставляемого файла.

Результат Отображает сведения о параметрах окна диалога или выбранном объекте.

Назад | Содержание | Вперед

 



Главная     Программы     Статьи     Разное     Форум     Контакты