Техническая поддержка :

Современные решения

для защиты Windows программ

и восстановления исходного кода

Руководство по Visual Basic


Меню Visual Basic

В Visual Basic существует два типа меню: встроенные и контекстные.

Встроенные меню

Встроенные меню выводятся в строке меню, над верхней границей окна Visual Basic. Название каждого меню отражает содержащиеся в нем команды. Например, меню "Формат" содержит команды, предназначенные для форматирования формы. Некоторые команды вызывают подменю с более подробными командами. Например, выбор команды "Панели" инструментов из меню "Вид приводит" к появлению подменю с названиями панелей инструментов и командой "Настройка". Эта команда служит для изменения встроенных меню или добавления в строку меню новых команд.

Контекстные меню

Контекстные меню содержат наиболее часто используемые команды и появляются при нажатии правой кнопки мыши или клавиш SHIFT+F10.

Примечание. Сведения о команде или меню можно получить с помощью меню "?".

Команда "Масштаб"

Эта команда служит для уменьшения или увеличения изображения выбранной формы. Допускается выбор или ввод коэффициента масштабирования в пределах от 10 до 400 процентов.

Команда доступна только на панели инструментов "UserForm".

Панель инструментов

Команда "Описание" (контекстное меню)

Эта команда выводит в окне модуля место описания переменной или процедуры, на имя которой установлен указатель. Если описание находится в библиотеке, на которую имеется ссылка, оно выводится в окне просмотра объектов.

Команда "Показать скрытые компоненты" (контекстное меню окна просмотра объектов)

Эта команда показывает или скрывает в окне просмотра объектов скрытые компоненты каждого класса. Скрытые компоненты не предназначены для использования в программах и обычно не выводятся в окне просмотра объектов. Они отображаются светло серым текстом.

Команда "Настройка" (контекстное меню)

Эта команда выводит окно "Настройка" для добавления, удаления, изменения или создания специальных панелей инструментов.

Команда "Удалить контрольное значение" (контекстное меню)

Эта команда служит для удаления контрольного значения.

Команда "Только слово целиком (Поиск)" (контекстное меню окна просмотра объектов)

Эта команда позволяет найти текст, в точности совпадающий с введенным в поле поиска в окне просмотра объектов.

Команда "Скрыть" (контекстное меню)

Команда служит для скрытия активного окна, проекта, папки, модуля или панели элементов управления.

Команда "Свернуть родительский объект" (контекстное меню)

Команда служит для скрытия элементов родительского объекта в областях Локальные и Контрольные окна отладки. При скрытии элементов списка, значок минус (-) слева от выражения изменяется на плюс (+).

Команда "Свойства" (контекстное меню)

Эта команда выводит окно "Свойства" для выбранного объекта.

Команда "Установить/снять" (контекстное меню)

Точка останова. Устанавливает или удаляет точку останова на текущей строке.

Закладка. Устанавливает или удаляет закладку на текущей строке в окне модуля.

Команда "Переместить" (контекстное меню)

В зависимости от того, является ли активным окно или панель элементов, выполняются следующие действия:

Указатель мыши принимает форму и становится возможным перемещение активного окна.

Появляется окно диалога Порядок страниц для изменения порядка страниц в панели элементов.

Допускается перемещение выбранной страницы в влево или вправо относительно других страниц.

Команды "Закомментировать блок" и "Раскомментировать блок"

Эти команды служит для добавления или удаления символа комментария, апострофа, в каждую строку выделенного блока текста. Если в момент вызова команд нет выделенного текста, символ комментария добавляется в строку, содержащую указатель.

Закомментировать блок Добавляет символ комментария в каждую строку выделенного блока теста.

Раскомментировать блок Удаляет символ комментария из каждой строки выделенного блока теста.

Команда "Свойства" (контекстное меню окна просмотра объектов)

Выводит окно диалога Параметры компонента, в котором задается описание специального компонента, а также присваивается идентификатор экрана справки и имя файла справки.

Команда доступна только для элементов, содержащих инструкции Basic.

Команда "Справка" (контекстное меню)

Выводит разделы справочной системы, относящиеся к выделенному элементу.

Команды "Объект" и "Программа" (контекстное меню)

Эти команды позволяют выбрать либо окно конструктора, либо окно модуля.

Объект Отображает или активизирует выбранный элемент.

Программа Отображает или активизирует окно модуля для выделенного объекта.

Команда "Закрепление" (контекстное меню)

Переключает способность активного окна фиксировать свое положение.

Окно считается закрепленным, когда его положение на экране, в окне приложения или в другом закрепленном окне зафиксировано. При перемещении такого окна оно остается "привязанным" к своему положению. Если окно может быть перемещено и оставлено в новом месте - оно не закреплено.

Команда "Компоненты группы" (контекстное меню окна просмотра объектов)

Переключает режим отображения компонентов класса между списком по алфавиту и списком компонентов, сгруппированных по типам.

Команда "Описания" (контекстное меню окна просмотра объектов)

Выводит описание выделенного компонента.

Команда "Размер" (контекстное меню)

Указатель преобретает другую форму и становится возможным изменение размеров активного окна или панели инструментов.

Команда "Копировать" (контекстное меню окна просмотра объектов)

Эта команда служит для копирования текста для выделенного класса или компонента в буфер обмена.

Подстановочные знаки, используемые при сравнении строк

Встроенное сопоставление с шаблоном предоставляет гибкий инструмент для сравнения строк. В следующей таблице показаны подстановочные знаки, используемые с оператором Like, и наборы цифр или строки, которым они соответствуют.

Символ(ы) в шаблоне

Соответствует в выражении

 

?

Любой одиночный символ

*

Ноль или более символов

#

Любая одиночная цифра (09)

[списокСимволов]

Любой одиночный символ, входящий в списокСимволов

[!списокСимволов]

Любой одиночный символ, не входящий в списокСимволов

Группа из одного или более символов (списокСимволов), заключенный в скобки ([ ]), служит для сопоставления с любым одиночным символом в выражении и может содержать практически все символы из набора символов ANSI, включая цифры. Особые символы - открывающая скобка ([ ), знак вопроса (?), знак номера (#) и звездочка (*) - могут использоваться непосредственно для сопоставления только когда заключены в скобки. Закрывающая скобка ( ]) внутри группы не может использоваться для этой цели, но может использоваться вне группы, как отдельный символ.

Помимо просто списка символов, заключенных в скобки, списокСимволов может задавать диапазон символов посредством дефиса (-), разделяющего нижнюю и верхнюю границы диапазона. Например, использование в шаблоне [А-Я] приведет к совпадению, если соответствующий символ в выражении содержит любую заглавную букву в диапазоне от А до Я. Несколько диапазонов включаются в скобки без всяких разделителей. Например, [а-яА-Я0-9] сопоставимо с любым буквенно-цифровым символом.

Ниже перечислены другие важные правила сопоставления с шаблоном:

Восклицательный знак (!) в начале спискаСимволов означает, что сопоставление выполняется, только если символ из выражения не входит в списокСимволов. При использовании вне скобок восклицательный знак сопоставляется только с собой.

Использование дефиса (-) для сопоставления с собой допускается либо в начале (после восклицательного знака, если таковой присутствует), либо в конце спискаСимволов. В любой другой позиции дефис служит для задания диапазона символов ANSI.

При указании диапазона символов границы следует задавать в порядке возрастания (А-Я или 0-100). [А-Я] является допустимым шаблоном, а [Я-А] - нет.

Символьная последовательность [ ] не принимается во внимание; полагается, что это строка нулевой длины ("").

Команда "Закрыть" (контекстное меню)

Зарывает выбранное окно.

Команды "Шаг с заходом", "Шаг с обходом" и "Шаг с выходом" (меню "Отладка")

"Шаг с заходом" Выполняет одну инструкцию программы.

Если команда "Шаг с заходом" выполняется не в режиме конструктора, на текущей строке выполнения осуществляется переход в режим прерывания. Если инструкция является вызовом процедуры, будет выведена первая инструкция этой процедуры.

Во время разработки эта команда запускает выполнение и входит в режим прерывания, прежде чем выполнится первая строка программы.

При отсутствии текущей точки выполнения команда "Шаг с заходом" не осуществляет никаких действий, пока не будет активирована программа, например выбором документа с помощью мыши.

Кнопка панели инструментов: . Клавиша быстрого вызова: F8.

"Шаг с обходом" Похожа на команду "Шаг с заходом". Различие проявляется, только если текущая инструкция содержит вызов процедуры.

Команду "Шаг с обходом" выполняет процедуру за один шаг и затем переходит к следующей инструкции текущей процедуры. Поэтому инструкцией, выводимой на следующем шаге, является следующая инструкция текущей процедуры, независимо от того, содержит ли текущая инструкция вызов процедуры. Команда доступна только в режиме прерывания.

Кнопка панели инструментов: . Клавиша быстрого вызова: SHIFT+F8.

"Шаг с выходом" Выполняет оставшиеся строки процедуры, в которой находится текущая точка выполнения. Следующей выводимой инструкцией является инструкция, следующая за вызовом этой процедуры. Выполняются все строки программы между текущей и конечной точками выполнения. Команда доступна только в режиме прерывания.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+SHIFT+F8.

Команда "Выполнить до текущей позиции" (меню "Отладка")

При работе в режиме конструктора команда "Выполнить до текущей позиции" служит для задания инструкции, находящейся ниже по тексту программы, на которой необходимо остановить выполнение. Программа выполняется от текущей до выбранной инструкции в строке индикатора на полях, напротив текущей строки выполнения, появляется индикатор на полях .

Эта команда полезна, например, для пропуска больших циклов.

Клавиша быстрого вызова: CTRL+F8.

Команда "Точка останова" (меню "Отладка")

Команда служит для установки или удаления точки останова в текущей строке программы. Невозможно установить точку останова в строке, содержащей неисполняемые инструкции, например комментарии, инструкции описания или пустые строки.

Строка программы, в которой установлена точка останова, приобретает цвет, заданный на вкладке "Модуль" в окне диалога "Параметры".

Кнопка панели инструментов: . Клавиша быстрого вызова: F9.

Команда "Снять все точки останова" (меню "Отладка")

Эта команда удаляет все точки останова из проекта. В этом случае возможно прерывание программы, если установлено контрольное выражение или на вкладке "Общие" окна диалога "Параметры" выбран параметр Останов при любой ошибке. Отменить действие команды "Снять все точки останова" нельзя.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+SHIFT+F9.

Команда "Следующая инструкция" (меню "Отладка")

Устанавливает точку выполнения на выбранную строку программы. Для установки строки, которая будет выполняться после текущей инструкции, следует выбрать нужную строку программы и выполнить команду "Следующая инструкция" или с помощью мыши переместить индикатор текущей выполняемой строки на полях в нужную строку.

С помощью этой команды допускается выбор строки программы, расположенной как до, так и после текущей инструкции. При запуске программы промежуточные строки не выполняются. Эта команда полезна для повторения инструкции внутри текущей процедуры, а также для пропуска нежелательных инструкций. С помощью команды "Следующая инструкция" невозможно установить точку выполнения на инструкцию в другой процедуре.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+F9.

Команда "Отобразить следующую инструкцию" (меню "Отладка")

Выделяет цветом следующую выполняемую инструкцию. Эта команда используется для помещения курсора на строку, которая будет выполняться следующей.

Команда доступна только в режиме прерывания.

Кнопка панели инструментов: .

Команда "Добавить контрольное значение" (меню "Отладка")

Эта команда выводит окно диалога "Добавление контрольного значения" для задания контрольного выражения. Это значение может быть любым допустимым в Basic выражением. Контрольные выражения обновляются в окне отладки каждый раз при входе в режим прерывания.

Кнопка панели инструментов: .

Команда "Изменить контрольное значение" (меню "Отладка")

Эта команда выводит окно диалога "Изменение контрольного значения" для редактирования или удаления контрольного выражения. Команда доступна только при установленном контрольном выражении, даже если окно отладки скрыто.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+W.

Команда "Контрольное значение" (меню "Отладка")

Эта команда выводит окно диалога "Контрольное значение" с текущим значением выделенного выражения. Эта команда служит для просмотра текущего значения переменной, свойства или другого выражения, для которого не задано контрольное выражение. Выделите выражение в окне модуля или в окне отладки и затем выполните команду "Контрольное значение". Для добавления контрольного выражения из окна диалога "Контрольное значение" следует нажать кнопку "Добавить".

Кнопка панели инструментов: . Клавиша быстрого вызова: SHIFT+F9.

Окно диалога Добавление контрольного значения

Используется для ввода контрольного выражения. Вводимое выражение может быть переменной, свойством, вызовом функции или любым другим допустимым в Basic выражением. Контрольные выражения в области Контрольные окна отладки обновляются каждый раз при входе в режим прерывания, а также после выполнения каждой инструкции в окне проверки.

Допускается перетаскивание с помощью мыши выделенного выражения из окна модуля в область Контрольные окна отладки.

Важно. При выборе контекста контрольного выражения всегда следует использовать самую узкую область определения, удовлетворяющую поставленной задаче. Выбор всех процедур или всех модулей может значительно замедлить выполнение, поскольку контрольное выражение вычисляется после выполнения каждой инструкции. Выбор в качестве контекста отдельной процедуры влияет на выполнение только в те моменты, когда эта процедура находится в списке активных вызовов, что можно наблюдать, выбрав команду Стек вызова из меню Вид.

Параметры окна диалога

Выражение По умолчанию отображает выделенное в окне модуля выражение. Выражение может быть переменной, свойством, вызовом функции или другим допустимым выражением. Возможно его изменение.

Контекст Задает область определения переменных в контрольном выражении.

Процедура - Отображает имя процедуры, в которой определено выделенное выражение (по умолчанию). Задает процедуру(ы), в которых вычисляется контрольное выражение. Допускается выбор всех процедур либо отдельной процедуры.

Модуль - Отображает имя модуля, в котором определено выделенное выражение (по умолчанию). Допускается выбор всех модулей либо отдельного модуля для вычисления значения контрольного выражения.

Проект - Отображает имя текущего проекта. Вычисление выражений вне текущего проекта невозможно.

Тип контрольного значения Определяет реакцию Visual Basic на контрольное выражение.

Контрольное выражение - Отображает в области Контрольные окна отладки выражение и его значение. При входе в режим прерывания значение этого выражения автоматически обновляется.

Останов, если значение истинно - Выполнение программы автоматически прерывается, когда значение выражения становится истинным или ненулевым (недопустимо для строковых выражений).

Останов при изменении значения - Выполнение программы автоматически прерывается при изменении значения выражения в указанном контексте.

Окно диалога Изменение контрольного значения

Используется для удаления или изменения содержания или типа контрольного выражени.

Важно. При выборе контекста контрольного выражения всегда следует использовать самую узкую область определения, удовлетворяющую поставленной задаче. Выбор всех процедур или всех модулей может значительно замедлить выполнение, поскольку контрольное выражение вычисляется после выполнения каждой инструкции. Выбор в качестве контекста отдельной процедуры влияет на выполнение только в те моменты, когда эта процедура находится в списке активных вызовов.

Параметры окна диалога

Выражение По умолчанию отображает выделенное в окне модуля выражение. Выражение может быть переменной, свойством, вызовом функции или другим допустимым выражением. Возможно его изменение.

Контекст Задает область определения переменных в контрольном выражении.

Процедура - Отображает имя процедуры, в которой определено выделенное выражение (по умолчанию). Задает процедуру(ы), в которых вычисляется контрольное выражение. Допускается выбор всех процедур либо отдельной процедуры.

Модуль - Отображает имя модуля, в котором определено выделенное выражение (по умолчанию). Допускается выбор всех модулей либо отдельного модуля для вычисления значения контрольного выражения.

Проект - Отображает имя текущего проекта. Вычисление выражений вне текущего проекта невозможно.

Тип контрольного значения Определяет реакцию Visual Basic на контрольное выражение.

Контрольное выражение - Отображает в области Контрольные окна отладки выражение и его значение. При входе в режим прерывания значение этого выражения автоматически обновляется.

Останов, если значение истинно - Выполнение программы автоматически прерывается, когда значение выражения становится истинным или ненулевым (недопустимо для строковых выражений).

Останов при изменении значения - Выполнение программы автоматически прерывается при изменении значения выражения в указанном контексте.

Удалить Удаляет контрольное выражение.

Окно диалога Контрольное значение

Отображает текущее значение выделенного выражения. Эта функция полезна при отладке для просмотра текущего значения переменной, свойства или другого выражения.

Параметры окна диалога

Контекст Отображает имена проекта, модуля и процедуры, в которых определено контрольное выражение.

Выражение Отображает выделенное выражение.

Значение Отображает значение выделенного выражения. Текущее значение не выводится, если контекст выражения находится вне процедур, перечисленных в окне диалога Стек вызова.

Добавить Добавляет выражение в область Контрольные окна отладки.

Окно диалога Просмотр объектов

Отображает классы, свойства, методы, события и константы объектных библиотек и процедур проекта. Используется для поиска объектов, созданных в текущем или других приложениях.

Дополнительные сведения о просмотре объектов можно получить в разделе Просмотр объектов справочной системы.

Элементы управления

Поле Проект/Библиотека

Отображает список библиотек, прямо адресуемых из активного проекта. Добавление библиотек выполняется в окне диалога Ссылки. При выборе значения <Все библиотеки> одновременно отображаются все библиотеки.

Поле поиска текста

Содержит строку искомого текста. Допускается ввод или выбор строки. Поле содержит также 4 последних искавшихся в текущем проекте строки. В строке допускается использование стандартных подстановочных знаков Visual Basic.

Для поиска целых слов в контекстном меню следует выбрать команду Только слово целиком.

Кнопка Назад

Позволяет перейти к предыдущему выбранному месту в списке классов и компонентов. При каждом нажатии кнопки происходит возврат на одно положение, пока не будет достигнуто самое первое обращение к этим спискам.

Кнопка Вперед

При каждом нажатии повторяет первоначальный выбор в списке классов и компонентов, пока не будет достигнуто самое последнее обращение к этим спискам.

Кнопка Скопировать в буфер обмена

Копирует выделенный текст из списка компонентов или из области описания в буфер обмена. В дальнейшем возможна вставка этого текста в программу.

Кнопка Описание

Помещает курсор в окне модуля в место описания выделенного объекта из списка классов или компонентов.

Кнопка Справка

Отображает контекстную справку по выделенному в списке классов или компонентов объекту. Для получения справки также служит клавиша F1.

Кнопка Найти

Выполняет поиск библиотек, в которых встречается класс, свойство, метод, событие или константа, совпадающие с шаблоном, заданным в поле поиска текста, а также открывает панель Результаты поиска, содержащую сведения о найденных элементах.

Кнопка Показать/скрыть результаты поиска

Отображает или скрывает панель Результаты поиска. В этой панели выводятся результаты поиска в проекте или библиотеке, выбранных из списка Проект/Библиотека. Результаты выводятся в алфавитном порядке.

Список Результаты поиска

Отображает библиотеку, класс и компонент, удовлетворяющие условиям поиска. Содержимое панели Результаты поиска изменяется при изменении значения в списке Проект/Библиотека.

Список Классы

Отображает список всех доступных классов из библиотеки или проекта, выбранных в поле Проект/Библиотека. Если для класса существует программный текст, этот класс выделяется жирным шрифтом. Список всегда начинается с класса <глобальные>, компоненты которого доступны глобально.

Если выделен класс, но не указан компонент, будет выведен компонент по умолчанию (если таковой существует). Компонент по умолчанию помечается звездочкой (*) или определенным для данного компонента значком по умолчанию.

Список Компоненты

Отображает список компонентов выбранного класса, сгруппированных по типу и упорядоченных внутри каждой группы по алфавиту. Методы, свойства, события и константы, для которых имеется программный код, выделяются жирным шрифтом. Порядок сортировки изменяется командой Компоненты группы контекстного меню просмотра объектов.

Панель описания

Отображает описание компонента. Содержит ссылку для перехода к классу или библиотеке, к которой принадлежит компонент. Некоторые компоненты имеют также ссылку на свой родительский класс. Например, если в панели описания указано, что Команда1 имеет тип Кнопка, выбор этой надписи отобразит класс Кнопка.

Допускается перетаскивание с помощью мыши текста из панели описания в окно модуля.

Линия разбивки

Разделяет панели и позволяет изменять их размер. Существует между:

Списками Классы и Компоненты.

Списком Результаты поиска и списками Классы и Компоненты.

Списками Классы и Компоненты и панелью описания.

Окно диалога Стек вызова

Отображает список активных вызовов процедур в режиме прерывания. При выполнении процедуры она помещается в список активных вызовов. Если из этой процедуры вызываются другие, все они также добавляются в список. Процедуры удаляются из списка когда управления возвращается вызвавшей их процедуре. В список также добавляются процедуры, вызываемые в окне проверки.

Параметры окна диалога

БазаДанных.Модуль.Процедура Отображает список процедур.

Показать Помещает место вставки в точку вызова процедуры и на полях устанавливает маркер вызова .

Окно диалога Параметры компонента

Позволяет добавить справочные сведения или комментарии для процедуры, описанной в проекте.

Параметры окна диалога

Имя компонента Отображает имя элемента, выделенного в списке Классы или Компоненты.

Описание Позволяет задать строку, отображаемую в панели описания в окне диалога Просмотр объектов.

Файл контекстной справки Отображает связанный с выбранным элементом файл справки. Это значение задается в ячейке Файл контекстной справки на вкладке Общие окна диалога Свойства проекта.

Идентификатор справки Присваивает уникальное числовое значение идентификатору контекста. Это значение используется для поиска соответствующего раздела в файле справки из ячейки Файл контекстной справки при нажатии клавиши F1 или кнопки во время просмотра процедуры в окне диалога Просмотр объектов.

Окно диалога Настройка печати

Отображается при нажатии кнопки Настройка в окне диалога Печать.

Используется для выбора принтера, ориентации и размера страницы.

Параметры окна диалога

Принтер Позволяет задать принтер. Если принтер не выбран, печать будет осуществлена на принтере Windows по умолчанию.

Имя - Отображает список доступных принтеров.

Состояние - Отображает состояние принтера и его готовность к работе.

Тип - Отображает тип принтера.

Место - Отображает место размещения принтера. Ели принтер сетевой, выводит путь к серверу.

Заметки - Отображает физическое место размещения принтера, а также дополнительные сведения.

Свойства - Отображает окно диалога Свойства для выбранного принтера, где задаются дополнительные параметры, такие как используемая бумага и способ печати графики.

Бумага Позволяет выбрать размер и тип подачи бумаги (из доступных вариантов). Размеры и типы подачи бумаги зависят от выбранного принтера и изменяются при изменении принтера.

Размер бумаги - Отображает список доступных размеров бумаги.

Подача бумаги - Отображает доступные типы подачи бумаги для выбранного принтера.

Ориентация Позволяет выбрать книжную или альбомную ориентацию листа при печати.

Окно диалога Настройка

Позволяет настраивать панели инструментов и меню.

Вкладки

Панели инструментов Позволяет создавать, переименовывать, удалять или сбрасывать панели инструментов.

Команды Содержит команды, которые можно перетащить с помощью мыши в меню или панель инструментов.

Параметры Позволяет изменять размеры кнопок панелей инструментов, отображать подсказки и клавиши быстрого набора, добавлять в меню элементы анимации.

Кнопка вызова Помощника Отображает Помощника по Office.

Вкладка Панели инструментов (окно диалога Настройка)

Позволяет создавать, переименовывать, удалять или сбрасывать панели инструментов.

Параметры вкладки

Список Панели инструментов Отображает список встроенных в Visual Basic панелей инструментов, а также созданных пользователем. Если панель инструментов отображена, рядом с ней появляется отметка.

Примечание. Строку меню скрыть невозможно. Ее можно только сбросить.

Создать Отображает окно диалога Создание панели инструментов для ввода в поле Панель инструментов имени новой панели инструментов.

Переименовать Отображает окно диалога Переименование панели для ввода нового имени панели инструментов. Команда доступна только для панелей, определенных пользователем.

Удалить Удаляет определенную пользователем панель управления из текущего проекта. Команда доступна только для панелей, определенных пользователем.

Сброс Отменяет любые изменения, внесенные во встроенные панели инструментов и восстанавливает их первоначальное состояние. Команда доступна только для встроенных панелей.

Вкладка Команды (окно диалога Настройка)

Позволяет добавлять или изменять элементы управления в строке меню или панели инструментов. Допускается также изменение изображения кнопок и текста добавленных пользователем команд.

Параметры вкладки

Категории Отображает список различных категорий команд.

Команды Отображает список элементов управления, доступных для категории, выбранной в списке категорий. Допускается перетаскивание команды с помощью мыши в нужную панель инструментов. Для добавления команды в меню следует перетащить ее на соответствующий заголовок меню, а затем в нужное место раскрывшегося меню.

Описание Отображает краткую справку для выделенного элемента управления.

Изменить выделенный объект Позволяет изменить выделенную команду.

Сброс - Восстанавливает состояние команды по умолчанию.

Удалить - Удаляет команду.

Имя - Изменяет имя элемента управления. Клавиша быстрого вызова задается с помощью символа амперсант (&).

Копировать значок на кнопке - Копирует изображение кнопки в буфер обмена.

Вставить значок на кнопке - Вставляет изображение кнопки из буфера обмена.

Восстановить значок на кнопке - Восстанавливает заданное по умолчанию изображение кнопки.

Изменить значок на кнопке - Отображает окно диалога Редактор кнопок.

Выбрать значок для кнопки - Отображает список значков, из которого следует выбрать новое изображение кнопки.

Основной стиль - Для кнопок панели инструментов отображать только значок, для команд меню - значок и имя.

Только текст (всегда) - Отображать только имя команды.

Только текст (в меню) - Скрывает значок (если есть) для команды меню. Для кнопок панели инструментов не работает.

Значок и текст - Отображает значок и имя для панелей инструментов. Для команд меню не работает.

Начать группу - Для панелей инструментов перед элементом управления помещает разделитель. Запрещена, если элемент управления находится в самом начале панели инструментов.

Содержание | Вперед

 



Главная     Программы     Статьи     Разное     Форум     Контакты