Техническая поддержка :

Современные решения

для защиты Windows программ

и восстановления исходного кода

Руководство по Visual Basic


Вкладка Параметры (окно диалога Настройка)

Позволяет изменять внешний вид строки меню и панелей инструментов.

Параметры вкладки

Крупные значки Делает значки панели инструментов крупными.

Отображать подсказки для кнопок Включает и выключает режим отображения подсказки для кнопок.

Включать в подсказки сочетания клавиш Отображает в командах меню клавиши быстрого вызова.

Эффект при выводе меню Отображает список доступных эффектов анимации, применимых к меню.

Окно диалога Свойства проекта

Задает параметры настройки выбранного проекта.

Окно диалога Создание панели инструментов

Позволяет задать имя новой панели инструментов.

Параметры окна диалога

Панель инструментов Допускается ввод имени новой панели или использование имени по умолчанию. Имя по умолчанию различно для каждой панели инструментов и имеет вид: Настраиваемая1, Настраиваемая2 и т. д.

Окно диалога Переименование панели

Позволяет задать новое имя специальной панели инструментов.

Параметры окна диалога

Панель инструментов Задает новое имя панели инструментов.

Окно диалога Шрифт

Служит для изменения шрифта, его размера и/или начертания для текста и полей данных.

Параметры окна диалога

Шрифт Отображает список всех установленных в Windows шрифтов. При открытии окна диалога выбирается шрифт, использованный для форматирования выделенного элемента.

Начертание Отображает список четырех дополнительных атрибутов, применимых к выбранному шрифту:

Обычный - стандартное, неизмененное начертание

Полужирный - жирный шрифт

Курсив - наклонный шрифт

Полужирный курсив - жирный наклонный шрифт

Размер Отображает список стандартных размеров для выбранного шрифта. При открытии окна диалога выбирается размер шрифта, использованный для форматирования выделенного элемента, и этот размер отображается в первой строке списка размеров.

Допускается выбор размера из списка или его ввод в поле редактирования (если есть уверенность, что для текущего принтера установлены дополнительные размеры шрифта, или если используется масштабируемый шрифт).

Атрибуты Отображает два дополнительных атрибута, используемые для выделения выбранного шрифта.

Зачеркнутый - перечеркивает символы шрифта

Подчеркнутый - подчеркивает символы шрифта

Возможно задание любого сочетания атрибутов.

Образец Отображает образец выбранного шрифта. Показываются: шрифт, начертание, размер, атрибуты и цвет (если указан). Полезно использовать это поле для просмотра результатов подбора параметров форматирования.

Набор символов Отображает перечень входящих в состав шрифта наборов символов.

OK Применяет параметры шрифта к выделенному элементу отчета.

Отмена Отменяет все изменения шрифта и оставляет отчет в прежнем виде.

Значки, использующиеся в окне просмотра объектов и в окне модуля

Окно просмотра объектов и окно модуля содержат большое число значков, представляющих классы и их компоненты. Следующий список поясняет их значения.

Этот значок:

Представляет:

 

Свойство

Свойство по умолчанию

Метод

Метод по умолчанию

Событие

Константу

Модуль

Класс

Определяемый пользователем тип

Глобальный объект

Библиотеку

Проект

Встроенные ключевые слова и типы

Перечислимый тип

Команды Отменить и Вернуть (меню Правка)

Отменить Отменяет последнее действие редактирования, например ввод текста в окне модуля или удаление элемента управления. При удалении одного или более элементов удаления команда Отменить позволяет восстановить их и их свойства.

Кнопка панели инструментов . Клавиши быстрого вызова: CTRL+Z или ALT+BACKSPACE.

Примечание. В форме с помощью этой команды невозможно отменить команду Вырезать.

Вернуть Восстанавливает последнее изменение текста, изменение размера или положения элемента управления, если с момента вызова команды Отменить не произошло никаких действий.

Кнопка панели инструментов .

В случае редактирования текста команды Отменить и Вернуть позволяют восстановить до двадцати изменений.

Эти команды недоступны во время выполнения программы, если не были внесены изменения или если после редактирования были выполнены другие действия. Также, в случае больших изменений, выполнению команды Вернуть может помешать нехватка памяти.

Команды Вырезать, Копировать, Вставить (меню "Правка")

Вырезать Удаляет выделенный текст или элемент управления и помещает его в буфер обмена. Чтобы сделать команду доступной необходимо выделить хотя бы один символ или элемент управления. Допускается отмена команды Вырезать над элементом управления.

Кнопка панели инструментов: . Клавиши быстрого вызова: CTRL+X или SHIFT+DELETE

Копировать Копирует выделенный текст или элемент управления и помещает его в буфер обмена. Чтобы сделать команду доступной необходимо выделить хотя бы один символ или элемент управления. Отмена команды Копировать в окне модуля невозможна.

Кнопка панели инструментов: . Клавиши быстрого вызова: CTRL+C или CTRL+INSERT.

Вставить Вставляет содержимое буфера обмена в текущую позицию. Текст помещается туда, где находится курсор.

Вставляемые элементы управления помещаются в центр формы.

Допускается отмена команды Вставить в окне модуля и в форме, если в нее был вставлен элемент управления.

Кнопка панели инструментов: . Клавиши быстрого вызова: CTRL+V или SHIFT+INS.

Команды Найти и Найти далее (меню "Правка")

Найти Выполняет поиск указанного в окне диалога Поиск текста в заданном диапазоне.

В случае успешного поиска окно диалога закрывается и выделяется найденный и текст. Если совпадение не обнаружено, выводится окно с сообщением о том, что указанный текст не найден.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+F.

Найти далее Выполняет поиск и выделяет следующее вхождение текста, заданного в поле Образец окна диалога Поиск.

Кнопка панели инструментов: . Клавиши быстрого вызова: F3 (найти далее) или SHIFT+F3 (найти предыдущее вхождение).

Параметры окна диалога

Образец В это поле следует ввести или вставить искомый текст либо нажать стрелку вниз и выбрать один из четырех последних использовавшихся образцов. Если при вызове команды выделен текст или курсор находится на слове, этот текст будет помещен в поле Образец.

Область поиска Задает диапазон поиска.

Текущая процедура-Поиск выполняется только в текущей процедуре.

Текущий модуль-Поиск выполняется только в текущем модуле.

В текущей базе данных-Поиск выполняется во всех модулях текущей базы данных.

Выделенный текст-Поиск выполняется в выделенном блоке текста.

Просмотр Устанавливает направление поиска: Вверх, Вниз от положения курсора или Все в выбранном диапазоне.

Только слово целиком Выполняет поиск целого слова и игнорирует его вхождения в более длинные слова.

С учетом регистра Выполняет поиск вхождений с комбинацией строчных и заглавных букв, указанной в поле Образец.

Использовать шаблон Выполняет поиск с использованием подстановочных символов.

Найти далее Выполняет поиск и выделяет следующее вхождение текста, заданного в поле Образец.

Отмена Закрывает окно диалога без выполнения поиска.

Заменить Выводит окно диалога Замена, сохраняя текст, введенный в окне диалога Поиск.

Команда Заменить (меню "Правка")

Команда выполняет поиск указанного текста в модуле текущей базы данных и заменяет его на новый текст, заданный в окне диалога Замена.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+H.

Параметры окна диалога

Образец В это поле следует ввести или вставить искомый текст либо нажать стрелку вниз и выбрать один из четырех последних использовавшихся образцов. Если при вызове команды выделен текст или курсор находится на слове, этот текст будет помещен в поле Образец.

Заменить на В это поле следует ввести или вставить из буфера обмена текст замены. Для удаления из документа текста, указанного в поле Образец следует оставить поле Заменить на пустым.

Область поиска Задает диапазон поиска.

Текущая процедура-Поиск выполняется только в текущей процедуре.

Текущий модуль-Поиск выполняется только в текущем модуле.

В текущей базе данных-Поиск выполняется во всех модулях текущей базы данных.

Выделенный текст-Поиск выполняется в выделенном блоке текста.

Просмотр Устанавливает направление поиска: Вверх, Вниз от положения курсора или Все в выбранном диапазоне.

Только слово целиком Выполняет поиск целого слова и игнорирует его вхождения в более длинные слова.

С учетом регистра Выполняет поиск вхождений с комбинацией строчных и заглавных букв, указанной в поле Образец.

Использовать шаблон Выполняет поиск с использованием подстановочных символов.

Найти далее Выполняет поиск и выделяет следующее вхождение текста, заданного в поле Образец.

Отмена Закрывает окно диалога без выполнения замены.

Заменить Запрашивает подтверждение перед каждой заменой искомого текста.

Заменить все Выполняет замену всех вхождений искомого текста на текст замены, не запрашивая подтверждения.

Команда Увеличить отступ (меню "Правка")

Смещает все выделенные строки в следующую позицию табуляции. Все выделенные строки смещаются на одинаковое число пробелов, при этом сохраняются относительные отступы между ними.

Изменение интервала табуляции выполняется на вкладке Редактор окна диалога Параметры.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+M.

Команда Уменьшить отступ (меню "Правка")

Смещает все выделенные строки в предыдущую позицию табуляции. Все выделенные строки смещаются на одинаковое число пробелов, при этом сохраняются относительные отступы между ними.

Изменение интервала табуляции выполняется на вкладке Редактор окна диалога Параметры.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+SHIFT+M.

Команды Закладки (меню "Правка")

Выбор этой команды приводит к появлению меню, позволяющему создавать или удалять закладки в окне модуля, переходить к следующей или предыдущей закладке или удалять все закладки.

При добавлении закладки рядом с текущей строкой появляется значок .

Закладка Снимает или устанавливает закладку.

Кнопка панели инструментов:

Следующая закладка Перемещает место вставки к следующей закладке.

Кнопка панели инструментов:

Предыдущая закладка Перемещает место вставки к предыдущей закладке.

Кнопка панели инструментов:

Снять все закладки Удаляет все закладки.

Кнопка панели инструментов:

Команда Выделить все (меню "Правка")

Эта команда служит для выделения всего текста в окне модуля или всех элементов управления в форме.

Команда Список свойств/методов (меню "Правка")

В окне модуля выводит раскрывающийся список, содержащий доступные для объекта свойства и методы. Если указатель установлен на пустой строке, команда Список свойств/методов выводит список глобально доступных методов. Чтобы список при наборе текста открывался автоматически необходимо выбрать параметр Список компонентов на вкладке Редактор окна диалога Параметры.

Поиск свойства или метода в списке выполняется путем:

Ввода имени. По мере ввода, подходящее свойство или метод выделяется и перемещается в начало списка.

Использования клавиш управления курсором вверх и вниз для перемещения по списку.

Прокрутки списка и выбора желаемого свойства или метода.

Вставка выделенного свойства или метода в инструкцию выполняется путем:

Двойного щелчка мышью на свойстве или методе.

Выделения свойства или метода и нажатия клавиши TAB для вставки или ENTER для вставки и перехода к следующей строке.

Примечание. После точки (.) в объектах типа Variant список не выводится.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+J.

Команда Список констант (меню "Правка")

В окне модуля выводит раскрывающийся список, содержащий допустимые константы для введенного свойства, за которым следует знак равенства (=). Допускается также применение этой команды к функциям, значением которых являются константы. Чтобы список при наборе текста открывался автоматически необходимо выбрать параметр Список компонентов на вкладке Редактор окна диалога Параметры.

Поиск константы в списке выполняется путем:

Ввода имени.

Использования клавиш управления курсором вверх и вниз для перемещения по списку.

Прокрутки списка и выбора желаемой константы.

Вставка выделенной константы в инструкцию выполняется путем:

Двойного щелчка мышью на константе.

Выделения константы и нажатия клавиши TAB для вставки или ENTER для вставки и перехода к следующей строке.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+SHIFT+J.

Команда Краткие сведения (меню "Правка")

Выводит синтаксис использования выбранной в окне модуля переменной, функции, инструкции, метода или процедуры.

Эта команда отображает синтаксис и выделяет текущий параметр. Для функций или процедур с параметрами параметр выделяется жирным шрифтом по мере его ввода, до тех пор пока не введена запятая, отделяющая его от следующего параметра.

Чтобы краткие сведения появлялись при наборе текста автоматически необходимо выбрать параметр Краткие сведения на вкладке Редактор окна диалога Параметры.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+I.

Команда Сведения о параметре (меню "Правка")

Эта команда в окне модуля выводит сведения о параметрах начальной функции или инструкции. Если функция или инструкция содержит в качестве параметров другие функции, команда Сведения о параметрах выведет сведения только о первой функции. Для получения сведений по всем вложенным функциям служит команда Краткие сведения.

Параметр выделяется жирным шрифтом по мере его ввода, до тех пор пока не введена запятая, отделяющая его от следующего параметра.

Вызванные Сведения о параметре не исчезнут пока:

Не введены все требуемые параметры.

Функция не завершена без указания необязательных параметров.

Не нажата клавиша ESC.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+SHIFT+I.

Команда Завершить слово (меню "Правка")

Завершает ввод набираемого слова, если только введено достаточно символов для распознавания слова Visual Basic.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+SPACEBAR.

Команда "Печать" (меню "Файл")

Команда позволяет распечатать формы и тест программ на принтере, указанном в Панели управления Microsoft Windows.

Кнопка панели инструментов: . Клавиша быстрого вызова: CTRL+P.

Параметры окна диалога

"Принтер" Определяет принтер, используемый для печати.

"Диапазон печати Определяет диапазон печати:

"Выделенный текст - Печать выделенного текста программы.

"Текущий модуль - Печать формы и/или текста программы для выделенного модуля.

"Текущий проект - Печать формы и/или текста программы для всего проекта.

"Печатать Задает распечатываемый объект. Допускается выбор любого числа параметров, в зависимости от значения диапазона печати.

"Рисунок формы - Печать изображения формы.

"Программу - Печать текста программы в выбранном диапазоне.

"Качество Определяет качество печати: высокое, среднее, низкое или черновик.

"Печать в файл" Если это флажок установлен, результат печати направляется в файл, указанный в окне диалога "Печать в файл". Оно появляется после нажатия кнопки "OK" в окне диалога "Печать".

"OK" Начало печати.

"Отмена" Закрытие окна диалога, не выполняя печать.

"Установка" Вывод стандартного окна диалога "Параметры страницы".

Команды Выровнять (меню "Формат")

Эти команды служат для выравнивания выделенных объектов относительно друг друга с использованием в качестве основы элемента управления с белыми маркерами захвата.

По левому краю Выравнивает горизонтальное положение выбранных объектов, помещая их левые границы на одну линию с элементом управления с белыми маркерами захвата.

Кнопка панели инструментов: .

По центру Выравнивает горизонтальное положение выбранных объектов, помещая их центры на одну линию с элементом управления с белыми маркерами захвата.

Кнопка панели инструментов: .

По правому краю Выравнивает горизонтальное положение выбранных объектов, помещая их правые границы на одну линию с элементом управления с белыми маркерами захвата.

Кнопка панели инструментов: .

По верхнему краю Выравнивает вертикальное положение выбранных объектов, помещая их верхние границы на одну линию с элементом управления с белыми маркерами захвата.

Кнопка панели инструментов: .

По середине Выравнивает вертикальное положение выбранных объектов, помещая их середины на одну линию с элементом управления с белыми маркерами захвата.

Кнопка панели инструментов: .

По нижнему краю Выравнивает вертикальное положение выбранных объектов, помещая их нижние границы на одну линию с элементом управления с белыми маркерами захвата.

Кнопка панели инструментов: .

По узлам сетки Помещает верхний левый угол выделенных объектов в ближайший узел сетки. Размер объектов не изменяется.

Кнопка панели инструментов: .

Команда Выровнять размер (меню "Формат")

Беря за основу объект с белыми маркерами захвата, корректирует размеры выделенных объектов в выбранном направлении.

по ширииине Корректирует ширину.

Кнопка панели инструментов: .

по высоте Корректирует высоту.

Кнопка панели инструментов: .

по ширииине и высоте Корректирует как ширину, так и высоту.

Кнопка панели инструментов: .

Команда Интервал по горизонтали (меню "Формат")

Изменяет расстояние по горизонтали между выделенными объектами.

Выровнять интервал по горизонтали Перемещает выделенные объекты, беря за основу крайние, так что расстояния между ними становятся равными. Крайние объекты остаются на месте.

Кнопка панели инструментов: .

Увеличить интервал по горизонтали Увеличивает горизонтальный интервал на единицу сетки, беря за основу объект с фокусом. Когда объект приобретает фокус на его границах появляются белые маркеры. Размер единицы сетки изменяется на вкладке Общие окна диалога Параметры.

Кнопка панели инструментов: .

Уменьшить интервал по горизонтали Уменьшает горизонтальный интервал на единицу сетки, беря за основу объект с фокусом. Когда объект приобретает фокус на его границах появляются белые маркеры. Размер единицы сетки изменяется на вкладке Общие окна диалога Параметры.

Кнопка панели инструментов: .

Устранить интервал по горизонтали Удаляет горизонтальный интервал, беря за основу объект с фокусом, так, что объекты касаются друг друга краями. Когда объект приобретает фокус на его границах появляются белые маркеры.

Кнопка панели инструментов: .

Примечание. Объект с фокусом не перемещается, зато вокруг него перемещаются остальные объекты.

Примечание. Если выполнение команды Интервал по горизонтали не привело к ожидаемому результату, следует переместить некоторые объекты вручную и затем повторить команду. Также бывает полезно использовать команду Интервал по вертикали.

Команда Интервал по вертикали (меню "Формат")

Изменяет расстояние по горизонтали между выделенными объектами, беря за основу объект с фокусом. Когда объект приобретает фокус на его границах появляются белые маркеры.

Выровнять интервал по вертикали Перемещает выделенные объекты, беря за основу самый верхний и нижний, так что расстояния между ними становятся равными. Крайние объекты остаются на месте.

Кнопка панели инструментов: .

Увеличить интервал по вертикали Увеличивает вертикальный интервал на единицу сетки, беря за основу объект с фокусом. Размер единицы сетки изменяется на вкладке Общие окна диалога Параметры.

Кнопка панели инструментов: .

Уменьшить интервал по вертикали Уменьшает вертикальный интервал на единицу сетки, беря за основу объект с фокусом. Размер единицы сетки изменяется на вкладке Общие окна диалога Параметры.

Кнопка панели инструментов: .

Устранить интервал по вертикали Удаляет вертикальный интервал, беря за основу объект с фокусом, так, что объекты касаются друг друга краями.

Кнопка панели инструментов: .

Примечание. Объект с фокусом не перемещается, зато вокруг него перемещаются остальные объекты.

Примечание. Если выполнение команды Интервал по вертикали не привело к ожидаемому результату, следует переместить некоторые объекты вручную и затем повторить команду. Также бывает полезно использовать команду Интервал по горизонтали.

Команда Разместить по центру в форме (меню "Формат")

Располагает выделенные объекты на центральных осях формы.

по горизонтали Располагает середины выделенных объектов на одной горизонтальной линии в середине формы.

Кнопка панели инструментов: .

по вертикали Располагает центры выделенных объектов на одной вертикальной линии в центре формы.

Кнопка панели инструментов: .

Команда Выровнять размер по сетке (меню "Формат")

Изменяет высоту и ширину выделенного объекта до ближайшей линий сетки в форме. Размер сетки изменяется на вкладке Общие окна диалога Параметры.

Кнопка панели инструментов: .

Команда Порядок (меню "Формат")

Изменяет порядок выделенных объектов в форме.

На передний план Помещает выделенные объекты в форме перед всеми остальными.

Кнопка панели инструментов: . Клавиши быстрого вызова: CTRL+J.

На задний план Помещает выделенные объекты в форме позади всех остальных.

Кнопка панели инструментов: . Клавиши быстрого вызова: CTRL+K.

Переместить вверх Перемещает выделенный объект на один шаг упорядочения по z выше.

Кнопка панели инструментов: .

Переместить вниз Перемещает выделенный объект на один шаг упорядочения по z ниже

Кнопка панели инструментов: .

Назад | Содержание | Вперед

 



Главная     Программы     Статьи     Разное     Форум     Контакты